Phoca Gallery

From Wikipedia, the free encyclopedia
Jump to: navigation, search
Phoca Gallery
Developer(s) Jan Pavelka
Stable release 4.0.2 / 16 August 2013 (2013-08-16)
Operating system Cross Platform
Platform PHP
License GPL
Website www.phoca.cz/phocagallery/

Phoca Gallery is an open source project, an image gallery run in Joomla! CMS. It is programmed in PHP and run on web server with enabled PHP support and installed Joomla!. It includes component, modules and plugins and allows users to display images or YouTube videos in many different styles.

Phoca Gallery allows displaying images uploaded on the server or from Picasa[1] or Facebook[2] applications.

For displaying images on the website with help of Phoca Gallery, only component needs to be run. Images can be displayed in articles created by Joomla! with help of Phoca Gallery plugin.[3] Phoca Gallery Image module displays images from Phoca Gallery in Joomla! module positions[4]

Phoca Gallery is standard Joomla! extensions and it can be extended by plugins and modules. There are many different modules and plugins for Phoca Gallery listed on Joomla! extensions directory.[5]

History[edit]

Phoca Gallery 4 is the current release of Phoca Gallery. It is based on Phoca Gallery 3 and overwritten for Joomla 3. Phoca Gallery 4.0.2 was released on August 16, 2013.[6]

Phoca Gallery 3 is a complete rewrite of Phoca Gallery 2 and works in Joomla 1.6 or 1.7 or 2.5. Phoca Gallery 3.2.3 was released on December 30, 2012.[7]

Phoca Gallery 2 was released on September 28, 2008.[8] Many new features were added to Phoca Gallery 2, so Phoca Gallery was not more a simple gallery but full featured gallery for Joomla! CMS.

Phoca Gallery 1 was released on September 20, 2007.[9] It was simple image gallery which didn't include many features.

List of versions with release and support info
Version Release date Supported until
1.0.0 2007-09-20 2009-07-22No
2.0.0 2008-09-28 Yes
3.0.0 2011-06-22 Yes
3.2.3 2012-12-30 Yes
4.0.2 2013-08-16 Yes
  No Release no longer supported
  Yes Release still supported

Requirements[edit]

Phoca Gallery 4 is running under Joomla! 3, so it requires:[10]

Phoca Gallery 3 requires:[11]

  • MySQL 5.0.4 or greater
  • PHP version 5.2.4 or greater
  • Joomla! version 1.6 or 1.7 or 2.5 or greater

Examples[edit]

These are examples of websites using Phoca Gallery:


See also[edit]

Further reading[edit]

References[edit]

  1. ^ Displaying Google Picasa Web Albums Retrieved on September 19, 2011.
  2. ^ Displaying Facebook Albums Retrieved on September 19, 2011.
  3. ^ Phoca Gallery Plugin Retrieved on September 19, 2011.
  4. ^ Phoca Gallery Image Module Retrieved on September 19, 2011.
  5. ^ Phoca Gallery Extensions Retrieved on September 19, 2011.
  6. ^ Phoca Gallery 4.0.2 Component and Plugins Released Retrieved on August 16, 2013.
  7. ^ Phoca Gallery Component 3.2.3 Released Retrieved on December 30, 2012.
  8. ^ Phoca Gallery Features Retrieved on September 19, 2011.
  9. ^ Phoca Gallery Features Retrieved on September 19, 2011.
  10. ^ Joomla! - TECHNICAL REQUIREMENTS Retrieved on January 14, 2013.
  11. ^ Phoca Gallery 3 Retrieved on September 19, 2011.
  12. ^ Google Books
  13. ^ Google Books
  14. ^ Google Books

External links[edit]