Zikula

From Wikipedia, the free encyclopedia
  (Redirected from Postnuke)
Jump to: navigation, search
Zikula
Developer(s) Zikula Development Team
Initial release 10. June 2008 (2008-06-10)[1]
Stable release Zikula 1.3.6[2] / November 7, 2013 (2013-11-07)
Development status Active
Written in PHP
Operating system Cross-platform
Available in Multilingual
Type Content Management System and Web Application Framework
License GNU General Public License
Website zikula.org

Zikula is a free open source web application framework released under the GNU General Public License. It can be used to develop robust, secure, interactive and editable websites and web based applications. Zikula is written in object oriented PHP and is fully modular. It requires a database and may use leading platforms like MySQL, PostgreSQL, Oracle Database and Microsoft SQL Server. Development of the program began as a successor to the PostNuke framework, and as of 2008 replaced it as the focus of all new development.[3] Earlier PostNuke development also influenced other still active projects, such as Xaraya.[4]

Features[edit]

Development[edit]

Zikula follows an active development cycle aiming toward frequent releases. Project milestones and roadmap are posted at the Zikula Code Roadmap. Many 3rd party developers build and contribute to extensions for the Zikula Application Framework which are often developed and hosted at Zikula Code website. Extensions perform tasks like blogging, storing and displaying data, such as images, music, forums, and shopping carts.

Release history[edit]

Legend: Old version Older version, still supported Current version Latest preview version Future release
Release history
Branch Version Release date Release notes (significant changes)
1.0 Old version, no longer supported: 1.0.0 2008-06-09
  • First release
Old version, no longer supported: 1.0.1 2008-07-17
  • Bug fixes
Old version, no longer supported: 1.0.2 2008-08-04
  • Bug fixes
Old version, no longer supported: 1.0.3 2008-12-21
  • Bug fixes
1.1 Old version, no longer supported: 1.1.0 2008-12-21
Old version, no longer supported: 1.1.1 2009-02-02
  • Bug fixes
Old version, no longer supported: 1.1.2 2009-06-18
  • Bug fixes
1.2 Old version, no longer supported: 1.2.0 2009-11-05
  • New language management system utilising gettext
  • UTF-8 support[5]
Old version, no longer supported: 1.2.1 2010-01-26
Old version, no longer supported: 1.2.2 2010-02-08
Old version, no longer supported: 1.2.3 2010-04-20
Old version, no longer supported: 1.2.4 2010-08-21
Old version, no longer supported: 1.2.5 2011-01-24
Old version, no longer supported: 1.2.6 2011-03-12
Old version, no longer supported: 1.2.7 2011-05-02
Old version, no longer supported: 1.2.8 2011-09-09
Older version, yet still supported: 1.2.9 2012-04-30
  • Security fixes[14]
1.3 Old version, no longer supported: 1.3.0 2010-08-21
  • Moved minimum PHP version to 5.3.2
  • Removed support for PHP register_globals and magic_quotes_gpc
  • Created new OO MVC module format
  • Introduced Doctrine 1 and 2
  • Created a new Zikula.UI ajax interface and library.[15]
Old version, no longer supported: 1.3.1 2011-09-18
  • Bug fixes
Old version, no longer supported: 1.3.2 2012-02-21
Old version, no longer supported: 1.3.3 2012-03-08
Old version, no longer supported: 1.3.4 2012-10-05
Current stable version: 1.3.5 2012-12-07

See also[edit]

References[edit]

External links[edit]