User:JaneVannin/translations/bitmaps

From Wikipedia, the free encyclopedia
Jump to: navigation, search
(To merge with tutorials: Gdaldem hillshade ; Projection ; and topgraphic data improvement.)

Relief bitmap graphics cartography tutorial

The aim of this tutorial is to create, fairly rapidly, a good quality topographical bitmap map derived from a digital elevation model (DEM) resulting from the Shuttle Radar Topography Mission (SRTM). The map will be created with the program 3DEM [1] [2].

While the map obtained is a topographic map, its main use in Wikipedia will be different: the different altitude ranges are represented as a colour gradient which does not allow the precise determination of the edges of each level of altitude. In order to create a truly topographic map, see the Topographic vector mapping tutorial.


End result

The type of map here presented can thus be applied more usefully to cases where the representation of the relief is important but the determination of altitude levels is not required. For example, these maps will be of use in the visualisation of the strategic analysis of an event, where the representation of the relief will facilitate comprehension of the terrain.

The tools[edit]

  • PC with 32 bit Microsoft Windows operating system (Win 95/98/Me/2000, XP or Vista) [3];
  • 3DEM (version used: 20.0): free and easy-to-use GIS editor with which the map will be created (topographical data and relief shading);
  • GIMP (version used: 2.2.13): bitmap editor which will allow modification of the map (dimensions, orientation), optimize the relief shading and integrate the coastal and lake outline data;
  • GRASS GIS (version used: winGRASS6.3.0RC6): free software GIS program used to open the SWBD files which are in the proprietary shapefile format of the ESRI, to reproject them as a UTM projection, then to export them in SVG format. These files contain the corrected coastal traces, [4]lakes and watercourses of a certain size which will complete the map;
  • Inkscape (versions used: 0.45 et 0.46): open source vector graphics editor with which the final SWBD map will be created.

nb need to create a page for swbd (srtm water body data)

Data sources[edit]

For other available resources, consult Wikipedia Map resources

These are the files released into the public domain, compressed into .zip format, which contain the digital topographic data of the region considered. The zone covered by the DEMs resulting from the SRTM extend from latitude 56° South to latitude 60° North. These files must be decompressed before being used in 3DEM. There are three SRTM file types:
  • SRTM1 (download here): the most precise data with a resolution of one arcsecond (31 m at the equator), but which are only available for the United States and its dependencies. Each file represents a rectangle of a degree of an arc to a side referenced according to the coordinates of the bottom left corner.[5].
  • SRTM3 (download here): a precision of three arcseconds (93 m at the equator) which covers all emerged land between the latitudes indicated above. Filetypes and references identical to SRTM1. These are the datasets which will be of most use for the needs of Wikipedia.
  • SRTM30 (download here): a precision of 30 arcseconds (926 m at the equator), adapted for maps covering more than one country or a continent.
Each map covers a region of 50° of latitude by 40° of longitude, referenced according to the coordinates of the upper left corner. Each map is contained in a specific folder which contains 12 separate files. Only 10 of these will be of use to us; the remaining files *.jpg.zip and *.gif.zip are just preview files. These 10 files must each be downloaded and decompressed before being used in 3DEM. In the program, select the GTOPO30 Tile option, then in the new window representing the map of the world, centre the frame on the region of interest and specify a Lat/Lon projection. Navigate through the menu and select the .DEM file.
  • NASA SRTM Water Body Data (SWBD) (download page) : complementary files to the SRTM containing the precise outline of coasts, lakes and watercourses of a certain size


Creation of the topographic map[edit]

1. Download the required SRTM files and unzip them.


Loading the terrain models
2. Open 3DEM. Click File -> Load Terrain Model (1). Select the SRTM Data option (2) then all of the .hgt files in the new window. Confirm with Open.


Filling the empty pixels
3. As the DEM contains pixels without information[6], it is necessary to fill them: press F7 et use the mouse to select the whole map (1). 3DEM fills in these pixels by interpolating the values from adjacent pixels (2).


Modification of the default colours
4. Application of the French Wikipedia topographic map colour convention: open Color Scale -> Modify Scale (or press F3). In the new window, indicate for each altitude segment the new RGB values corresponding to the Wikipedia convention colours; start with 9 to 11 different colours beginning from the lowest altitude. For the highest levels, choose the same colour as that representing the highest altitude segment. Do the same for the sea (values R: 218 - G: 240 - B: 253).


5. Save this colorimetric scale by clicking on the Save File button in order to be able to reuse the scale for other maps, for example under the name « 11 value WP colour scale » (the scale can be recalled using the Load File button).



Modification de l'équidistance
6. Observer les deux valeurs dans la section Altitude Range : elles indiquent les valeurs altimétriques extrêmes trouvées par 3DEM dans le MNT[7]. Diviser le nombre du champ Max par le nombre de tranches de couleurs différentes. Arrondir le résultat à la valeur de l'entier immédiatement supérieur ; multiplier ce chiffre par 14 (le nombre total de tranches dans 3DEM) et entrer le résultat en cliquant sur le bouton Modify pour remplacer l'altitude maximale. Cette opération permet de placer l'altitude maximale du MNT dans la dernière tranche de couleur représentative que vous avez choisie. Les tranches supérieures d'une même couleur ne seront en fait pas utilisées[8]. Remplacer la valeur de l'altitude minimale (normalement négative si la carte comporte une côte) par 0. Valider en cliquant sur le bouton Apply. Dans la section Terrain Colors, l'intervalle entre les tranches d'altitudes (équidistance) est recalculé par 3DEM.
Exemple appliqué à la capture d'écran ci-contre :
701 m / 11 couleurs = 63,72 m par tranche d'altitude
63,72 arrondi à 64 m
64 m x 14 tranches au total = 896 m : l'altitude « 701 m » est bien située à l'intérieur de la dernière tranche d'altitude représentative (la onzième).


7. Dans la section Terrain Type, sélectionner l'option Island/Ocean si la carte comporte une côte. Valider l'ensemble des choix en cliquant sur le bouton OK : la carte s'affiche avec les nouvelles couleurs.
Tutorial raster topo map 05a.jpg
Tutorial raster topo map 05b.jpg
Activer l'option Island/Ocean La carte avec les couleurs conventionnelles de WP-fr


Modification de l'illumination
8. Modifier l'illumination de la carte : par défaut, 3DEM utilise un éclairage venant du Sud-Ouest (240° - coin inférieur gauche) qui est naturel, mais en cartographie la norme veut que l'illumination vienne du Nord-Ouest (coin supérieur gauche). Cet éclairage, impossible dans la réalité pour l'hémisphère Nord, est devenu une convention et évite en particulier l'illusion d'optique d'inversion du relief pour laquelle on a l'impression de voir des vallées comme des montagnes et inversement. Cliquer sur Color Scale -> Shaded Relief et modifier le champ Deg Azimuth pour 315. Valider.


9. Modifier la projection : Operation -> Change Projection -> Convert to UTM Projection (1). Sélectionner l'option WGS84 (2) qui est le système géodésique utilisé par les fichiers SRTM. Valider. La carte est retracée et les méridiens, auparavant parallèles, sont à présent convergents vers les pôles.
Tutorial raster topo map 07a.jpg
Tutorial raster topo map 07b.jpg
Modification de la projection La carte suivant une projection UTM


Exemple de la Grèce s'étendant sur plus d'un fuseau UTM
10. Si en validant apparaît un message indiquant que la carte est trop grande et qu'il faut d'abord la redimensionner, c'est que votre carte couvre plus d'un fuseau UTM, opération de fusion que 3DEM n'est à l'heure actuelle pas capable de traiter. Il est alors nécessaire de redimensionner la carte : appuyer F8 et sélectionner avec la souris une zone moins large sur toute la hauteur de la carte puis valider avec ENTER. Procéder à la modification de la projection comme indiqué au point 8. Cette action devra être répétée pour l'autre partie de la carte en rechargeant les MNT correspondants dans 3DEM et les opérations reprises depuis le point 3.


Vérification des altitudes max et mini de la carte
11. Appuyer sur F3 et vérifier que les valeurs des altitudes maximales et minimales de la carte sont bien celles que vous avez spécifiées plus haut.


Redimensionnement de la carte
12. Redimensionner la carte : appuyer sur F6 et déplacer le curseur jusqu'aux valeurs largeur / hauteur en pixels désirées. Valider.


Exporter un aperçu de la carte
13. Exporter un aperçu de la carte : vérifier que le quadrillage des coordonnées soit affiché (Geo Coordinates -> Lat-Lon Grid On) (1), aller dans File -> Save Map Image (2) et sélectionner le format jpeg (3), valider et indiquer un nom pour l'image. Enregistrer. Cette carte compressée au format .jpg n'est destinée qu'à servir de référence grâce aux coordonnées pour faciliter les transformations nécessaires sur la carte finale (rotation, alignement des calques, etc.).


14. Modifier le type de terrain : le tracé des côtes des MNT de la SRTM étant imprécis, ce sont les SWBD qui seront utilisés et appliqués en tant que calque par dessus la carte. Pour éviter d'avoir à corriger plus tard l'intervalle qui existera entre le tracé des côtes des MNT et celui des SWBD, appuyer sur F3 et sélectionner dans la section Terrain Type l'option Mountain/Plain : 3DEM va considérer que la carte ne contient pas de surface aquatique et appliquera pour les altitudes inférieures à celle spécifiée (0 m) la même couleur que celle de la première tranche d'altitude.
Tutorial raster topo map 12a.jpg
Tutorial raster topo map 12b.jpg
Sélectionner l'option Mountain/Plain La carte avec la mer de la couleur des plaines


Suppression des ombrages
15. Exporter la carte : enlever le quadrillage des coordonnées (Geo Coordinates -> Lat-Lon Grid Off) (1). À ce niveau, vous avez deux possibilités concernant l'ombrage du relief : soit vous optez pour la solution basique qui consiste à exporter la carte avec l'ombrage appliqué. Ceci est plus rapide mais présente le désavantage de ne pas pouvoir optimiser la représentation des structures importantes d'un relief, en particulier si celui-ci est orienté Nord-Ouest / Sud-Est, donc dans l'axe de l'éclairage général. Si vous choisissez cette solution, exportez la carte telle quelle : File -> Save Map Image et sélectionner le format bmp pour ne pas dégrader la qualité de l'affichage (la carte ne sera enregistrée au format .jpg que lorsqu'elle sera finalisée). Entrer un nom pour la carte et valider. La seconde possibilité concernant l'ombrage implique d'exporter les ombres séparément en tant que calque (en réalité trois calques) afin d'être optimisées. Dans ce cas, supprimer les infos de l'ombrage en cliquant sur Color Scale -> Shaded Relief (2) et en spécifiant dans le champ Shade Depth (%) la valeur 0 (3). Valider puis exporter cette carte sans ombrage au format .bmp (4) pour une qualité optimale.


16. Exporter les ombres du relief. Pour cette opération et l'optimisation des calques, se reporter au didacticiel d'optimisation des ombres du relief. Fermer 3DEM.

Création de la carte des SWBD[edit]

Création de la carte finale[edit]

Préparation de la carte SWBD[edit]

Importer la carte bitmap dans celle des SWBD
1. Ouvrir dans Inkscape la carte SWBD vectorisée. Importer (CTL + I) l'aperçu de la carte DEM (celle avec les grilles et la mer de couleur bleue au format .jpg) et placer-la en-dessous.


Spécifier la dimension du document
2. Éditer les préférences du document (CTL + MAJ + D) et spécifier dans les champs Largeur et Hauteur les dimensions en pixels de la carte JPG. Aligner cette carte sur le document (X=0 ; Y=0). Ou plus simplement, sélectionner l'aperçu 3DEM et cliquer sur le bouton < Ajuster la page à la sélection >.


Redimensionner les SWBD
3. Sélectionner les deux chemins. Cliquer sur le bouton représentant un cadenas afin de forcer un redimensionnement proportionnel de la largeur et de la hauteur du document. Redimensionner les chemins en modifiant la valeur L ou H et les positionner convenablement (champs X et Y) afin qu'ils se superposent parfaitement aux contours de la carte bitmap issue de 3DEM sur l'ensemble de la carte.


Créer un fond bleu
4. Supprimer la carte bitmap. Créer un rectangle de la taille du document, sans bordure et le remplir du bleu de la convention colorimétrique (#DAF0FD) qui représentera la mer. Placer ce rectangle sous les chemins.


Supprimer le bleu des terres émergées
5. Sélectionner le chemin représentant les côtes. Le dupliquer (CTL + D). Appuyer sur la touche MAJ et sélectionner aussi le rectangle bleu. Cliquer sur Chemin -> Exclusion : les terres émergées deviennent transparentes. Enregistrer le document puis l'exporter au format .png. Fermer Inkscape.


Montage de la carte finale[edit]

Ouvrir les différentes cartes
1. Ouvrir dans GIMP la carte issue de 3DEM (celle avec la mer couleur verte au format .bmp). Ouvrir respectivement en tant que calques (CTL + ALT + O) :
Les trois calques doivent normalement parfaitement se superposer.


Appliquer aux ombres une fusion « Multiplier »
2. Activer le calque des ombres et lui appliquer une fusion « Multiplier ».


Corriger la luminosité
3. Ouvrir la boîte de dialogue de réglage des niveaux (CTL + L) et déplacer le curseur central des gris vers la gauche jusqu'à une valeur d'environ < 4,00 > pour laquelle le vert des zones planes (donc sans ombres) correspond sensiblement au vert original de ces mêmes zones (effectuer la comparaison en éteignant le calque des ombres). Valider. Enregistrer la carte au format .xcf.


Importer l'aperçu de la carte de 3DEM
4. Activer le dernier calque (celui issu des SWBD). Importer en tant que calque (CTL + ALT + O) l'aperçu de la carte de 3DEM avec les grilles des coordonnées.


Recadrer la carte
5. Réduire la taille de l'affichage. Avec l'outil de sélection rectangulaire (M), recadrer la carte pour sélectionner la zone qui vous intéresse. Cliquer sur Image -> Découper l'image pour recadrer la carte suivant la sélection. Désélectionner (CTL + D).


Mesurer l'angle de rotation nécessaire
6. Augmenter le zoom vers 400 % et sélectionner l'outil Mesure (U). Pointer la croix sur l'un des parallèles au niveau d'un bord de la carte. En maintenant le bouton gauche de la souris enfoncé, faire glisser la croix vers le bord opposé de la carte et relâcher le bouton après avoir pointé l'autre extrémité du parallèle. Dans la fenêtre de dialogue qui s'est ouverte, on peut lire la valeur de l'angle qui sera utilisée lors de la rotation de la carte afin que celle-ci soit d'aplomb (parallèles horizontaux, méridien central vertical).


Effectuer la rotation
7. Lier les quatre calques. Cliquer sur Outils -> Outils de transformation –> Rotation et indiquer la valeur de l'angle déterminée précédemment. Valider.


Récupérer la couleur de la mer
8. Activer l'onglet Couleur PP/AP et cliquer sur la pipette. Cliquer sur la mer pour récupérer cette couleur comme couleur de premier plan.


Remplir les triangles de bleu
9. Activer le calque issu des SWBD. Activer l'outil de sélection des régions contiguës (W), placer le seuil à < 0 >. Sélectionner les quatre triangles blancs résultant de la rotation. Activer l'outil Pot de peinture (MAJ + G) et remplir ces quatre zones du bleu de la mer. Désélectionner.
Remarque : Les points 8 et 9 indiquent la procédure pour des îles. Si votre carte couvre une zone continentale, le plus pratique sera, au point 5, de recadrer la carte en sélectionnant une zone un peu plus grande que vos besoins puis, pour les points 8 et 9, de recadrer une nouvelle fois pour supprimer les triangles blancs résultant de la rotation.


Carte finalisée
10. « Éteindre » le calque supérieur avec les grilles. Sauvegarder le document (toujours au format .xcf). Votre carte est à présent prête à être exportée au format .jpg pour être utilisée et recevoir les informations additionnelles (villes, routes, etc.). Pour les latitudes et longitudes, utiliser le quatrième calque avec ces grilles issu de 3DEM en l'exportant au format .jpg et tracer ces lignes dans Inkscape. Pour savoir comment ajouter ces informations complémentaires, se reporter au didacticiel d'intégration des données cartographiques complémentaires.


Notes[edit]

  1. ^ 3DEM produces errors in altitudes at the point of the reprojection of the map as a [UTM] which makes this program unusable for the production of a topographic map. This page is about the production of a relief map in which precision in altitude determination is not required, and so these errors will not be noticeable.
  2. ^ This page presents the creation of the map by using the program 3DEM, which is not available for Microsoft Windows, but the process can be entirely carried out using GRASS GIS or any other geographical information system (GIS). For this operation, see the article Topographic vector mapping, which one can adapt by exporting a bitmap view of the map with the colours as a gradient, instead of extracting each altitude level separately.
  3. ^ A problem with 3DEM is that the program is incapable of reading shapefile format files, which necessitates the use of another program (here GRASS GIS).
  4. ^ A defect of SRTM files is their lack of precision in coastal areas, particularly as a result of wave action which can produce a false radar reading. The SRTM Water Body Data (SWBD) files provided by NASA are intended to resolve this problem.
  5. ^ Example: the file N48E001.hgt.zip, (decompressed: N48E001.hgt), covers the zone between the 48° and 49° North and 001° and 002° East.
  6. ^ One of the problems with SRTM files is that, in spite of the fact that practically all emerged terrain has been overflown at least twice, certain zones have remained hidden from the oblique radar ray due to the sharply accidented relief, giving rise to voids in the map information.
  7. ^ Les MNT ne sont pas précis au mètre près. Ainsi, la valeur la plus haute trouvée peut différer de celle que vous pouvez connaître grâce à des cartes topographiques de référence. Dans l'exemple montré par la capture d'écran, 3DEM a trouvé dans le MNT une altitude maximale de 701 m. En réalité, le sommet le plus élevé des îles Malouines est le mont Usborne qui culmine à 705 m.
  8. ^ Cette opération n'est pas nécessaire si vous décidez d'utiliser une échelle colorimétrique à 14 valeurs.

Links[edit]

Gtk-dialog-info.svg

The table above has links to various tutorials and resources which can help in the creation of Wikipedia maps from digital georeferenced data (GIS).