Wikipedia:Huggle/Wine

From Wikipedia, the free encyclopedia
Jump to: navigation, search
Shortcuts:
Huggle2.19 working.

Note: this page is obsolete. It describes how to run old huggle (the one written in VB) on non-windows machines. Latest version of huggle is cross-platform and you don't need to follow these instructions for it

It is possible to run Huggle 2 on non-Windows OSs (please note that huggle 3 runs natively on linux as well as MacOS, don't use wine for that, it won't work ;)), using a program called Wine. Wine works on both Linux and Mac. Wine does not support the PowerPC architecture. Before following these instructions, you should have a valid Windows License. Please note that you'll need to use non-free libraries in order to get Huggle to run (on Windows, Mac OS X or GNU/Linux).

Instructions[edit]

  1. Ensure that you have X11 installed. If you are on Mac OS X Leopard, Snow Leopard, or Lion, you're fine. Tiger users must install it. Since X11 was removed in Mountain Lion, users will have to install XQuartz instead.
    Make sure you have enough space left on your device. A lot of software has to be installed that huggle depends on. A few GB should be enough.
  2. Download and install Wine
    Mac OS X: http://winebottler.kronenberg.org/wine/ (or use the MacPorts version of Wine (sudo port install wine))
    Linux: http://www.winehq.org/download
    Alternative for Debian and Ubuntu users: Type sudo apt-get install wine in the Terminal
  3. Open up the Terminal (Mac OS X: located in Applications/Utilities/Terminal.app)
  4. In the terminal:
    1. curl http://www.kegel.com/wine/winetricks > /tmp/winetricks
      If curl is not installed, install it (Ubuntu: sudo apt-get install curl) and re-run the command
    2. (Darwine users only) export PATH=$PATH:/Applications/Darwine/Wine.bundle/Contents/bin:~/Applications/Darwine/Wine.bundle/Contents/bin:"/Applications/TRiX.app/Contents/Resources/bin"
    3. sh /tmp/winetricks -q tahoma liberation gecko dotnet20 msi2 fontfix mono28 allfonts gdiplus ie8
      If cabextract is not installed, install it (Ubuntu: sudo apt-get install cabextract) and re-run the command
      Click through all installers that pop up.
  5. Download and open up Huggle. Good luck!

If you have any problems you can visit Huggle's page on the Wine App Database here [1] where you can ask for help and contact Wine developers.

Successful users[edit]

Machuggle.png
  1. Xclamation point 21:55, 1 May 2009 (UTC)
  2. Jake Wartenberg 21:56, 1 May 2009 (UTC)
  3. treelo radda 23:11, 1 May 2009 (UTC)
  4. haha, there we go. took running the last command a few times, and installing IE6 twice (That means when it prompted me, I selected the "reinstall all components option"), and it loads the diffs now. At the very least, the full version works. I have yet to test the lite version Both versions work. The font is ugly as sin though, and very small... and some things overlap other things so it looks rather ugly, but it still works :D. Until It Sleeps 21:14, 2 May 2009 (UTC)
  5. Some moderate success on Mac OS X for me. Still seems unstable, and the installers were all somewhat wonky, but after several do overs, it seems to be working "reasonably". —TheDJ (talkcontribs) 22:22, 6 May 2009 (UTC)
  6. Kinda wonky, but it's there. (Only tested main version 0.90) --Bfigura (talk) 18:41, 3 June 2009 (UTC)
  7. Slow and jerky, but it works. Isn't really worth it, though. Javert (T · C) 17:36, 22 July 2009 (UTC)
  8. Airplaneman talk 02:36, 23 August 2009 (UTC)
    Removed because it is too choppy. As Javert said, it's not really worth it (I can't keep up with the vandals!). Also, now suspiciously Time Machine isn't working... How do you make sure you've removed all the files you installed? Airplaneman talk 02:01, 27 August 2009 (UTC)
    Now using IG Airplaneman talk 04:48, 3 March 2010 (UTC)
  9. Works but above.. --Lcawte (talk) 13:40, 27 February 2010 (UTC)
  10. (Mostly) works on OS X Leopard (10.5.8) with Wine 1.2-rc2 (from MacPorts): The menu bar can't be drawn (but the menus still work if you know where to click), it pops up a few errors on startup (which can be dismissed), the fonts look absolutely terrible, and the program overall is a bit slow, but hey, it works! ~SpK 17:04, 30 May 2010 (UTC)
  11. Works, but its slow... LegoKontribsTalkM 02:31, 15 December 2010 (UTC)
  12. Got it working on Mac OS 10.6.6 with the WineBottler distro. I had the same menu bar issues and start-up error that SpK had above, but I was able to fix that by installing gdiplus as well using winetricks. Might want to add that to the instructions above if it won't break anything. Zachlipton (talk) 06:53, 3 February 2011 (UTC)
  13. After installing ie8 and gdiplus along with the others, it works perfectly, and has a Wine Platinum rating, which is very rare. --123Hedgehog456 : Create an account! 15:06, 19 March 2011 (UTC)
  14. Seems to work quite well under Wine, except IRC doesn't work. Calvin (t·c) 04:03, 29 May 2012 (UTC)
  15. works good (Ubuntu 11, Gnome3) --N.A....my talk (user pages are on german WP) 12:38, 17 June 2012 (UTC)
  16. I had trouble with this initially but fixed it by creating a new WINEPREFIX. --Krenair (talkcontribs) 15:07, 18 June 2012 (UTC)
  17. Works perfectly for me on Arch Linux. hajatvrc @ 19:25, 7 September 2012 (UTC)
  18. Running fine on OSX Lion Tarheel95 (Sprechen) 03:30, 28 January 2013 (UTC)
  19. Works fine through Wine. It's a Fox! (What did I break) 22:12, 3 May 2013 (UTC)
  20. No luck on OS X. Guess that's what Boot Camp is for. Haha Signalizing (talk) 17:03, 5 July 2013 (UTC)
  21. Worked on Macbook Air (Mac OS X Lion 10.7.5) :D -Newyorkadam (talk) 14:46, 12 February 2014 (UTC)Newyorkadam

Unsuccessful users[edit]

  • Launched on Linux, but requires the Windows version of Mono to be installed to the Wine directory. Unfortunately, diffs do not show up on-screen so you cannot tell what you can/can't revert. Cody574 00:02, 7 October 2010 (UTC)
  • Numerous Winetricks installation errors. Also, this guide is quite old. I just decided to do Boot Camp, which works well. Allmightyduck What did I do wrong? 16:23, 10 July 2010 (UTC)
  • In the Terminal when entering the third command I got "Cannot find cabextract. Please install it (e.g. 'sudo apt-get install cabextract' or 'sudo yum install cabextract')." Then I tried to open Huggle and I got: huggle 0.9.0.exe has exited with an error, have a look at the Log window... There I see: "fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly>

install the Windows version of Mono to run .NET executables" What should I do? Ag97 (talk) 17:23, 4 June 2009 (UTC)

  • While running winetricks, I got a bunch of: "err:ole:CoInitializeEx Attempt to change threading model of this apartment from apartment threaded to multi-threaded"
    • Followed by:
"err:msi:HANDLE_CustomType34 Unable to execute command L"\"C:\\windows\\Microsoft.NET\\Framework\\netfxsbs20.exe\" /install""
    • I am trying a clean wine install and will update as soon as I have news.--Res2216firestar 07:27, 2 May 2009 (UTC)
      • Pfft. The sudo purge whatever command-thing didn't purge my wine install. I'm looking into it.--Res2216firestar 07:40, 2 May 2009 (UTC)
        • Going to bed, will resume work in the morning.--Res2216firestar 07:51, 2 May 2009 (UTC)
          • Update: The above errors are harmless, and happen on windows machines in the logs. Huggle still won't start in Ubuntu 9.04.--Res2216firestar 18:56, 3 May 2009 (UTC)
  • Loads into huggle, then freezes. But I am trying to get it working with Mono, which is having more success (and would allow the creation of a native linux binary of huggle, no external software required). ~fl 12:39, 2 May 2009 (UTC)
    • FL, running the commands shown above should install mono automatically. Xclamation point 16:11, 2 May 2009 (UTC)
  • I get Greek (literally) as the font. The log begins with:

Running on OS X. AldaronT/C 23:05, 6 May 2009 (UTC)

If you get greek, then not all the font packages finished installing. Try using Trix.app to install "tahoma" and "allfonts". I think i ran all the installs in the end trough Trix.app, seemed to work more reliable than downloading winetricks manually in the Terminal —TheDJ (talkcontribs) 16:03, 11 May 2009 (UTC)
I used Trix (for "MS Tahoma" and all the other fonts listed; there was no "allfonts" listed), so now I can log in (Greek prevented before) but see nothing in Huggle browser pane when I click on a page in the queue. AldaronT/C 22:39, 11 May 2009 (UTC)

I'm running on Mac OS X. I got fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly> install the Windows version of Mono to run .NET executables when I tried to run huggle. --I dream of horses (talk) 01:45, 23 May 2009 (UTC)

  • Ubuntu Jaunty x64. IE6 installer crashed in winetricks. Installing IE6 in wine-doors didn't help either, still hangs on startup. --ausa کui × 20:57, 24 May 2009 (UTC)
  • I try and open up Huggle and I get "huggle 0.9.0.exe has exited with an error, have a look at the Log window..." Looking at the Log window, I see this:

Anyone who can help with this, it would be appreciated. --t'shael mindmeld 23:01, 29 May 2009 (UTC)Finally got it to work, so, moving to "successful" Javert (T · C) 17:39, 22 July 2009 (UTC)

The same thing has happened to me. Ag97 (talk) 19:58, 5 June 2009 (UTC)

  • I just installed it today on Ubuntu Jaunty, but it "hangs" every few seconds (program dims for a short period). I haven't been able to do anything with it yet. I'm going to look into compiling the source code for 'nix operating systems. [mad pierrot][t c] 20:54, 15 July 2009 (UTC)
Just kidding, it's written in Visual Basic. I thought it was in C++ or C#. Bummer :-/. [mad pierrot][t c] 20:56, 15 July 2009 (UTC)

Aw, so close, didn't work. Ubuntu 9.04 x64: The feed works, but the IE6 doesn't plug in properly, so I can't see the changes. Magog the Ogre (talk) 05:05, 27 July 2009 (UTC)

  • I continue to get this:
fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly>
install the Windows version of Mono to run .NET executables
{{collapse bottom}}

anyone have any ideas? Right now, I'm figuring out what the Windows version of Mono is. Until then, I will try not to drink after anyone who's coughing. Quintusπ talk 19:56, 2 February 2010 (UTC)

Okay. I installed the windows version of Mono, and now I'm getting this:
fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly>
fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly>
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
err:ole:apartment_createwindowifneeded CreateWindow failed with error 1114
fixme:gdiplus:GdipSetStringFormatFlags format (0x20b758) flags (4096)
fixme:gdiplus:GdipGetFontHeightGivenDPI Unhandled unit type: 3

** (/Users/quintus314/Downloads/huggle 0.9.2.exe:23): WARNING **: mono_class_from_mono_type: implement me 0xb6

**
ERROR:class.c:5166:mono_class_from_mono_type: code should not be reached
|}

Anyone? Ideas? Quintusπ talk 21:03, 2 February 2010 (UTC)

Get the following error:

Weird, yet interesting. — Parent5446 (message email) 05:01, 14 February 2010 (UTC)

Instead of Wine, try Mono for Linux; it works faster and less buggy than Mono on Wine (why when a Linux build is available). Devper94 (talk) 15:23, 19 February 2010 (UTC)


I'll give it a try.

{{collapse top}}
fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly>
wine: Unhandled exception 0x40000015 at address 0xd30023:0x7813461a (thread 0009), starting debugger...
Process of pid=0008 has terminated
No process loaded, cannot execute 'echo Modules:'
Cannot get info on module while no process is loaded
No process loaded, cannot execute 'echo Threads:'
process  tid      prio (all id:s are in hex)
0000000e services.exe
        00000016    0
        00000015    0
        00000014    0
        00000010    0
        0000000f    0
00000011 winedevice.exe
        00000018    0
        00000017    0
        00000013    0
        00000012    0
00000019 explorer.exe
        0000001a    0
You must be attached to a process to run this command.
No process loaded, cannot execute 'detach'
{{collapse bottom}}

Using wine-1.1.40, ran the Winetricks setup first. It looks like it will run fine on Mono after installing libmono-microsoft-visualbasic8.0-cil, as the login screen works, but sadly I can not test any deeper at the moment due to my permissions. Harry (talk) 04:46, 22 March 2010 (UTC)

  • I tried the winetricks line and got that for an answer:
sha1sum mismatch!  Rename /home/baruch/.winetrickscache/./tahoma32.exe and try again.

Althoug it's not a error in your prog but in theirs... Can you give me a lil hint how to get this workin?--Baruch ben Alexander - ☠☢☣ 03:23, 22 April 2010 (UTC)

  • Loads, but choppy - diffs do not load. THEMONO 16:40, 23 October 2010 (UTC)
  • Some of the winetricks packages don't work for 64-bit. --CyberDiablo 18:00, 18 January 2011 (UTC)
  • I'm running Snow Leopard. I entered 1 and 3 above, but after typing in the string at 3 I get the following message:
wine cmd.exe /c echo '%ProgramFiles%' returned empty string
What am I doing wrong? (Note that I am a Mac newbie.) --NellieBly (talk) 22:14, 3 April 2011 (UTC)
Same as above. --Matthew Thompson talk to me bro! 10:33, 11 August 2011 (UTC)


  • Got the following in wine after following directions:

True to its complaint, the toolbar fails to render. Not sure if slowness can be attributed to this issue, other issues, or Wine's general slowness. —Calvin 1998 (t·c) 02:33, 26 September 2011 (UTC)

I'm running Ubuntu 12.04, Wine 1.5.4 and trying to use Huggle 2.1.19. Console output is below in an HTML comment. Krenair (talkcontribs) 14:41, 17 June 2012 (UTC) Update: I now have this working by creating a new Wine prefix. --Krenair (talkcontribs) 15:07, 18 June 2012 (UTC)

Not quite working with wine under OS X 10.8 (Mountain Lion). Had to hand install a few pieces of wine (gecko, mono) and a few other things just to get it to launch. It seems to be running, but doesn't quite finish login failing with the messages below. Of course since I hand to install so many pieces of wine by hand - it's possible I've missed something that's not obvious to me.

 fixme:shell:URL_ParseUrl failed to parse L"Microsoft.VisualBasic"
 fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
 fixme:shell:URL_ParseUrl failed to parse L"System"
 fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
 fixme:shell:URL_ParseUrl failed to parse L"Accessibility"
 fixme:shell:URL_ParseUrl failed to parse L"System.Runtime.Remoting"
 fixme:gdiplus:GdipGetFamilyName No support for handling of multiple languages!
 fixme:shell:URL_ParseUrl failed to parse L"huggle2.resources"
 fixme:shell:URL_ParseUrl failed to parse L"huggle2.resources"
 fixme:gdiplus:GdipCreateHalftonePalette stub
 fixme:shell:URL_ParseUrl failed to parse L"System.Web"
 fixme:shell:URL_ParseUrl failed to parse L"System.Configuration"
 fixme:shell:URL_ParseUrl failed to parse L"System.Xml"
 fixme:ras:RasEnumConnectionsW (0x1d4938,0x533e828,0x533e824),stub!
 fixme:ras:RasEnumConnectionsW RAS support is not implemented! Configure program to use LAN connection/winsock instead!
 fixme:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request: stub
 fixme:ras:RasConnectionNotificationW (0xffffffff,0x240,0x00000003),stub!
 fixme:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request: stub
 fixme:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request: stub
 fixme:advapi:RegisterEventSourceW ((null),L".NET Runtime Optimization Service"): stub
 fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x00000457,0x0,0x0001,0x00000000,0x94eec4,0x0): stub
 err:eventlog:ReportEventW L".NET Runtime Optimization Service (clr_optimization_v2.0.50727_32) - Service reached limit of transient errors. Will shut down. Last error returned from Service Manager: 0x80004005.\n"
 fixme:advapi:DeregisterEventSource (0xcafe4242) stub
 fixme:advapi:RegisterEventSourceW ((null),L".NET Runtime Optimization Service"): stub
 fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x00000454,0x0,0x0001,0x00000000,0x94ef38,0x0): stub
 fixme:advapi:DeregisterEventSource (0xcafe4242) stub

This may be a wine issue, but I can't find any obvious thing to try to move beyond this. Hmm ... maybe I should try to be a Huggle 3 beta tester under OS X? dwmc (talk) 02:32, 4 February 2013 (UTC)

  • Nope; while running Terminal on Mac OS X v. 10.8.5, I got the following command: sudo: apt-get: command not found Epicgenius (talk) 02:10, 6 December 2013 (UTC)