LiveQuartz

From Wikipedia, the free encyclopedia
Jump to navigation Jump to search
LiveQuartz
LiveQuartz Icon 2018 128x128.png
LiveQuartz 2.8
LiveQuartz 2.8
Developer(s)Romain Piveteau
Initial releaseMay 2, 2005; 13 years ago (2005-05-02)
Written inObjective-C & Swift
Operating systemmacOS
TypeRaster graphics editor
LicenseProprietary
Websitewww.livequartz.com

LiveQuartz is a basic graphic editor developed for macOS by Romain Piveteau. Each document is in a single window with layers and filters on both sides, tools are displayed on the top and document settings or at the bottom in the status bar. LiveQuartz[1] features layers-based image editing, non destructive filters and selection, painting and retouching tools. LiveQuartz was one of the first public raster image editors built on top of Core Image to be made public. In may 2005, when the first beta of iMage (the original name of LiveQuartz) was released, its singularity was that it was the first graphic editor to use two new Mac OS X Tiger frameworks: Core Image and Core Data. LiveQuartz was also, back in early 2005, the first macOS X image editing app to use a unique window user interface without "palettes".

Features[edit]

  • Uses technologies like Cocoa (API), Quartz (graphics layer), Core Data and Core Image.
  • Uses layers-based editing and non destructive filters (filters can me merged onto their layer when using certain tools or when doing certain actions like cutting a selection, etc...).
  • Selection and retouch tools.
  • LiveQuartz provides unlimited (per document) undos (since app opening).
  • Integrates with macOS and applications such as Apple Photos. Support for Drag and Drop and standard image formats (JPEG, PNG, TIFF, HEIF).
  • Pictures can be imported a lot of different ways: They can be drag and dropped from Finder or other applications. They can be opened from the "File" menu. They can be shared from Apple Photos app. They can be taken with an iSight camera from within the app, imported from a scanner or plugged camera or with an iOS device having the same iCloud account as the mac with Camera Continuity in macOS Mojave.
  • Support for other macOS features such as multi-touch gestures, versions, auto save, and full screen mode.

Tools[edit]

Name Description Settings
Arrow tool Moving, cutting and copying layers or part of layers with selections.
Brush tool Paint with radial gradient shape. Size and color
Duplication tool Duplication of pixels. Reference point is chosen by clicking with the 'alt' key. Size
Drawing tools (line, rectangle, filled rectangle, filled oval) Draws shapes. With shift key, a constraint can be made. Circle for ovals, squares for rectangles, 45° or 90° for lines Size, color, corner radius (for rectangles)
Gradients tools (linear and radial) Draws gradients. Color 1, color 2
Text tool Generates a rich text layer. Color
Eraser tool Erase pixels with a radial gradient shape. Size
Background eraser and paint bucket tool Background eraser will remove all the pixels in the layer having the same color as the one found on the mouse down click. Color tolerance is adjusted by maintaining mouse clicked and moving further from the initial point. Paint Bucket will fill the clicked color with the tool color. A color tolerance can be changed the same way as the background eraser. Color
Spiral tool Used to set some filter point parameters. For example, when applying a bump distorsion, when the "center" parameter is selected in the filter parameter user interface, the spiral tool is selected so the user can choose the application point.
Color picker tool Used to set choose a color by clicking on the image. It picks the color with its transparency.
Rectangle selection tool Will select a rectangle part of the image to limit editing to this zone or to crop the document or layer. Color and border sharpness
Oval selection tool Will select an oval part of the image to limit editing to this zone or to crop the layer. Color and border sharpness
Lasso selection tool Will select part of the image with a polygon path to limit editing to this zone or to crop the layer. The lasso has to modes. A first mode is used by maintaining the mouse clicked and another by successive clicks. Color and border sharpness
Magnifying glass tool Used to increase or decrease the displayed size of the document. Color and border sharpness


Supported image file formats[2][edit]

Name Alpha channel support Write support
Rhapsoft Image Format (LiveQuartz save format) Yes Yes
Portable Network Graphics Yes Yes
JPEG No Yes
TIFF Yes Yes
HEIF Yes Yes
JPEG 2000 Yes Yes
PDF Yes Yes
GIF Yes (1 bit) Yes
KTX Yes Yes
BMP file format No Yes
Photoshop PSD (Limited support: It looses non destructive informations like layers, etc) Yes Yes
Truevision TGA Yes Yes
OpenEXR Yes Yes
PBM Yes Yes
X BitMap No No
ICO No No
PICT No No
QuickTime Image No No
Silicon Graphics Image No No
Mac Paint No No
FlashPix No No
Apple Icon Image format No No
Radiance No No
Raw No No

Version history (In decreasing dates order)[edit]

LiveQuartz[edit]

Release date Version Minimal macOS requirement Release Note
December 2018 2.8 10.11

New Features:

  • In Edit menu, the latest selection can be restored
  • As it is similar, the brand new “Paint Bucket” is available by choosing the background eraser tool with ‘alt’ key pressed
  • Drag and Drop of text layers is now possible (Previously, it would have converted the layer to a pixel image layer)
  • Default corner input points for certain transform filters now default to the current position of the corners (example: “Perspective Correction” filter)


Bug fixes:

  • Drag and drop of layers and filters between two LiveQuartz documents is back on Mojave
  • Fixing an issue on certain configurations with painting tools on Mojave (pencil and duplication tool)
  • Scrolling with input devices like the magic mouse is disabled while using tools to avoid wired behaviour
  • Fixing an english localisation issue in filter picker
  • Fixing a layer size issue with background eraser when using a selection
September 2018 2.7 10.11

New Features (macOS Mojave):

  • Support of Dark Mode
  • Linear gradient tool uses a better quality filter to generate the gradient image
  • New native dialog asking for an App Store review that will be displayed sometimes after exporting an image
  • Continuous camera support (‘ctrl’-clic or right clic on the layers’ list)

Bug fixes:

  • Fixing a sandbox issue preventing to import scanner or camera images on certain configurations
  • Prevent from a possible hang when opening documents (while building layer previews)
  • Fixing a crash preventing QuickLook to work properly
  • On Mojave, fixing a refresh issue when removing filters
  • On Mojave, fixing a bug preventing to change order of layers or filters with drag and drop
  • Note: The (temporary) workaround was to disable the possibility to drag and drop layers and filters between two LiveQuartz documents on Mojave. I hope to re-enable this functionality as soon as possible.
June 2018 2.6 10.11

Features:

  • Better performance when scrolling and window resizing thanks to use of core animation layer backed views (we are still

working on some performance enhancements for future updates)

  • Now, at least on Sierra, you can drag and drop one are several photos from Apple Photos app to LiveQuartz

Bug fixes:

  • Fixing a bug with alpha introduced with filters optimisation in 2.5.21
  • More efficient file size estimation
  • LITE: "Restore" button is back to be able to restore a previous purchase when it is not found automatically (new mac,

etc)

  • LITE: Dragging one or several layer(s) does not account anymore for the limit of one export per day
April 2015 -> Spring 2018 2.5: a special 10 years Birthday version of LiveQuartz 🎂 10.10
  • NewEllipseSelectiontool
  • Enhanced Lasso Selection tool with two modes : classical behaviour by using it as usual (click and drag and release the mouse to close the selection) OR the new polygonal mode where you do some successive clicks to define segments of the polygon. You close the selection path with the “ Close ” button or with the “ ↩︎ ” key (“ esc ” key is here to cancel the selection)
  • New selections settings to apply a blur effect on the selection borders (no blur effect by default)
  • Layer crop (available in the layer contextual menu by doing a right click on selected layers in the layer’s list) is now

possible to any types of selection. This gives new basic masking capabilities to LiveQuartz (rectangle, elliptic, lasso and polygonal masking with progressive borders in option).

  • Redesigned rectangle selections resizing knobs
  • Better feedback about the tool size values and more precise tool size settings for small sizes (the slider uses a loga-

rithmic slider)

  • Painting tools now have dynamic sized cursors to show the tool shape
  • Arrow tool (layer dragging) could be constrained to a line or vertical move with the “ ⇧ ” key
  • Rectangle selections could be constrained to squares with the “ ⇧ ” key
  • Ellipse selections could be constrained to circles with the “ ⇧ ” key
  • Fixes a bug with undo grouping on some drawing tools
  • Fixes a bug with cursors when we have selections
  • Fixes a bug with the background eraser when using it by clicking on a non opaque color
October 2014 2.4 10.10
  • Fully supports OS X 10.10 Yosemite with lot's of bug fixes
  • New rewritten iSight camera capture Panel (cmd-⇧-O)
  • Now LiveQuartz always opens images as rhif files.
  • Popovers can now be detached.
  • Note : 2.4 and higher will not support anymore versions of OS X prior to Yosemite. If your system is not up to date, you can download 2.3.3 for Lion, Mountain Lion or Mavericks.
April 2014 2.3 10.7.5
  • New Color Picker Tool (accessible with 'alt' key)
  • Scrolling Tool removed
09/2013 2.2 10.7.5
  • Some UI Bugs are fixed (window size problem in "versions" is fixed, etc)
  • Major bug when using Magic Eraser with selections is fixed
  • Larger rounded corners are now possible when drawing rectangles
  • Bigger maximum size of tools
  • New background Grid Guide size settings in preferences
  • New image scroll view background with a shadow (easier to see grey and black images)
  • More intuitive behaviour of all the application when working on layers having filters. For example when using the

eraser. The visible filters are automatically merged into the layer. If you want to keep some filters, disable them before making your changes to the layer.

  • Symmetry filter names fixed
  • New notification the first time we open a non rhif file to explain that saving it is destructive
  • Text Layer crop (layer's contextual menu)
  • Mavericks bugs fixes
  • New Lite version with In App Purchase
  • Ajout d’un système de crash reporting
03/2013 2.1 10.7.5
  • New actions available in layers' contextual menu : 'cut', 'copy' and 'crop'.
  • 'Crop' a layer is new in LiveQuartz. Before, only cropping a selection on all the document was possible. Now, you can crop image layers individually or by group. To be able to crop, you must select a rectangle with the selection tool and right clic or ctrl-click on the layer or the selected layers. Note that, as this action removes pixels that are outside the crop rectangle, this could be a technique to reduce memory usage and 'rhif' file size.
  • Drag and drop of filters to copy them to another layer of the same document or to another layer (or filters) of another document. So now, you can easily reuse your best filters by keeping all there custom parameters.
  • New lighter User Interface when entering "Versions" history on Mountain Lion
  • Limits on Layer name, image size, layer size and layer positions removed to avoid confusing errors with AutoSaving
  • Major Bug fixed when opening LiveQuartz 1 files
  • Cleaner way to handle migrations to version 2 when opening LiveQuartz 1 files. In LiveQuartz 2.0.x, files were moved into the sandbox. Now in LiveQuartz 2.1, a backup of the original file is put into LiveQuartz's sandbox but the migrated file (the one we use) does not move.
  • More robust handling of errors when opening files
  • Refresh bugs fixed when canceling or redoing actions on filters
08/2012 2.0 10.7.4
  • Built for Mountain Lion and Lion
  • “Sandbox” support
  • Full Screen support
  • Simplified and more modern UI with more contextual informations
  • New text layer UI (full text editor per text layer with rich text editing and alignment settings, etc)
  • More standard Filters added (110+ filters available)
  • Sharing popover menu support to export to popular social web sites like Twitter, Flickr, Email, AirDrop, Message and very soon : Facebook (only on Mountain Lion)
  • Auto Save support (only on Mountain Lion)
  • Versions support (only on Mountain Lion)
  • Updated file format RHIF
  • New “Export” menu to export a LiveQuartz image to popular image file formats
  • Retina Display support status : Critical bugs are fixed but some tools' bugs remain (drawing tools and selections).

Graphical User Interface is 90% ready for Retina Display. Support of ‘Retina image editing’ will be enhanced in next releases.

  • After adding a multiple pages PDF as a layer, we can choose the page in layer settings popover.
  • Precise positioning of layers
  • Possible to fill a layer with current color
  • QuickLook plug-in bug fixes
  • More stable Import from Device and Scanner UI (only on Mountain Lion)
  • Bug Fixes affecting LiveQuartz on Lion and Mountain Lion
02/2012 1.9.7 10.6.6
  • "Take a picture" picker is back to its standard size
  • Some bug fixes
07/2011 1.9.6 10.6.6
  • Bug fixes on Lion
04/2011 1.9.5 10.6.6
  • Facebook export
  • Help menu now has a direct link to the AppStore LiveQuartz page
03/01/2011 1.9.4 10.6.6
  • Fix a linear gradient color order issue
  • Works on Lion
02/05/2011 1.9.3 10.6.6
  • New app icon designed by NendoMatt (http://www.nendomatt.com)
  • Enhanced background eraser with progressive borders
  • Linear gradient : By pressing the ⇧ key during its usage, you can have increment angles of 45 degrees (same as the drawing tools)
  • By default, new documents have a 800 by 600 pixels size
  • Small UI adjustments
  • Bug fixes
01/13/2011 1.9.2 10.6.6
  • Add a setting in preferences for exporting with or without alpha background (for image formats supporting alpha)
01/06/2011 1.9.1 (Mac App Store) 10.6.6
  • LiveQuartz 1.9.1 is the first release available on the Mac AppStore
  • Bug fixes
  • Free line tool has been removed has it did not differentiated enough with the brush.
2011 1.9.0.1 10.6
  • LiveQuartz 1.9.0.1 is a Snow Leopard only release. Older versions remain available on the web site.
  • Bug fixes
01/26/2010 1.9 10.6
  • LiveQuartz 1.9 is a Snow Leopard only release. Older versions remain available on the web site.
  • Various Bug fixes and GrandCentralDispatch optimizations on Snow Leopard
  • Faster quit and better use of multiple CPUs
  • New “Flip” transformations added in geometry filter category (Horizontal and Vertical)
  • New “Shadow” filter added in stylize filter category
  • Better localization of filter parameters (with full explanation in the filter parameter panel)
  • Filters are represented in their order : top to bottom
  • Layer display offset bug resolved on transformed layers that have some filters
  • Pixel accurate image display and pixel accurate drawing when working precisely on pixels (except when using scale and rotation transformations or text)
  • Rewritten and fixed drawing tools
  • Rounded corner rectangle drawing tools
  • “Import from device...” added to import from scanners, digital cameras, iphones, etc...
  • “New from Clipboard...” menu added
  • New option on saving as flat image formats to keep alpha for the background or not
  • Window last position is saved
  • Pasting an image selection now pastes it at the same place as the original
10/02/2009 1.8.4 10.5
  • Bug fixes on Snow Leopard : PDF files opening
09/01/2009 1.8.3 10.5
  • Bug fixes on Snow Leopard
03/31/2009 1.8.2 10.5
  • Intel 64 bit binary added ! Now LiveQuartz will run in 64 bit if you have at least MacOS 10.5.6 on a Core2Duo or better.
  • Japanese Localization (thanks to Shintaro Ikegaki & Ryuta Kojima)
  • Preferences for default color and default font
  • New more simple livequartz-update system (http://sparkle.andymatuschak.org)
06/09/2008 1.8.1 10.5
  • New behaviour of drawing and gradient tools : By default, LiveQuartz is not creating a new layer each time you use the tool anymore (if you like the old behaviour, you can get it by typing this in the “terminal” application : “defaults write

com.rhapsoft.livequartz IMDrawingWithoutMerging YES”).

  • LiveQuartz keeps the current selected tool after drawing.
  • With “⇧” key pressed, rectangle and oval tools keep proportions 1:1. And with “⇧” key pressed, the line tool steps

45°.

  • When choosing “Save as...” to a standard image file format, you can see a preview of final file size.
  • A file opening bug has been fixed (when there are empty layers)
  • A very old bug with display of “lasso” selection doing some pauses is fixed
  • “RHIF” Spotlight plug-in bug fix
  • 1.8.1 only for MacOS 10.5.3 because LQ has some hanging issues on PowerPC with 10.5.2
04/16/2008 1.8 10.5
  • From release 1.8, LiveQuartz is Leopard MACOS 10.5 only !
  • LiveQuartz handles multi-touches (with compatible trackpads) : swipe (tools choice and selected layer choice), rotation (layer rotation) and magnifying (magnification and layer zoom transformation)
  • New free line drawing tool (click on the line tool sub-menu to choose it)
  • New standard Leopard filter picker with bookmarks ("Collections")
  • Background eraser's action can be restricted by a selection
  • More logical merging of layers : Now, only selected layers are merged
  • Global image resize is finally possible !
  • New tool settings user interface (only tools available for the current tool are displayed)
  • New line width setting for drawing tool
  • PDFs, text and drawing layers are correctly rendered (as long as we do not alter their content or use filters on them)
  • New "Take a picture" menu to use the standard picture taker of Leopard (snapshots from iSight camera)
  • Lot's of bug fixes
  • Memory usage optimizations
  • Faster launch times
  • Faster QuickLook plug-in (RHIF format)
  • QuartzGL (Faster display system) is available in preferences but is not enabled by default because there are too many display issues yet
04/01/2008 1.7.3 10.4
  • Bug fix : when pasting graphics, there was a blur effect
  • Bug fix : there was a bug on undo after opening a rhif document
  • Enhancement : tools' undo is grouped now
02/16/2008 version 1.7.2 10.4
  • Bug fix in "RHapsoft Image Format" save behaviour
11/17/2007 1.7.1 10.4
  • New setting in preferences for background grid color
  • Bug fix in the RHapsoft Image Format QuickLook importer
10/30/2007 1.7 10.4
  • Bug fix : In earlier versions, when exporting text which has alpha and no filter, text became opaque
  • New super easy to use background eraser tool (ONLY ON LEOPARD)
  • QuickLook ready (ONLY ON LEOPARD)
09/28/2007 1.6.5 10.4
  • Bug fixes for Leopard
05/29/2007 1.6.4 10.4
  • Leopard 10.5 ready
  • A potential bug that may cause a crash at start up has been fixed. The app may launch slower than previous builds but it is much safer.
10/06/2006 1.6.3 10.4
  • No preview icon anymore for files created with LiveQuartz to decrease small images' file size
  • While using tools on a layer, does not hide other layers anymore
  • Italian localization added thanks to Simone D.
06/10/2006 1.6.2 10.4
  • Third party CoreImage Image Units recognized (just put them in .../Library/Graphics/Image Units)
06/07/2006 1.6.1 10.4
  • Bug fixes
04/27/2006 1.6 10.4
  • Much more image formats supported (photoshop, row, etc)
  • Option to choose the compression of JPEG files
  • Many bugs fixes
  • Speed and memory optimizations
  • Better feedback of the spiral (filter) tool
  • Better behaviour of the text layer
  • New web site for LiveQuartz made by Loïc Villette
  • Spanish localization added thanks to Manuel Rives
04/07/2006 1.5.2 10.4
  • avoids a very serious deadlock when using painting tools with MacOS 10.4.6 (CoreImage bug)
01/15/2006 1.5.1 10.4
  • Fixes on Russian localization
  • Optimizations on copies
  • Bug fix on internal image handling
  • Traditional Chinese localization added
01/09/2006 1.5 10.4
  • Totally rewritten selection sub-system
  • New lasso selection tool
  • New linear and radial gradient tools
  • New feature : "Fill a selection with current color" (Edit menu)
  • New Interface look inspired from Apple iTunes 6 and Apple Mail 2
  • New alternate interface with all the settings in a drawer at the right of the window (available via preferences)
  • New preference option to hide settings on window opening
  • Bug fixes
  • New localization : Persian (Ali Samadi)
  • Universal binary compiled on XCode 2.2
11/01/2005 1.2 10.4
  • Selection tool has a new more classical and logical appearance * Scrollers are hidden now when not necessary
  • Drag and drop bug fixed (Had been introduced since 1.1)
  • Localizations completed (German and Chinese)
  • New localization : Russian (Michael Krekin)
09/13/2005 1.1 10.4
  • New 5 drawing tools : line, stroked rectangle, filled rectangle, stroked oval and filled oval
  • Painting tools' behaviour is correct now (fluid painting, no points anymore)
  • Tools are correctly enabled and disabled in toolbar
  • New shortcuts
  • Bug fixed with CoreImage pointing tool
  • Major regression crash bug fixed (undo of a new layer follow by any operation) introduced since 1.0.1
08/23/2005 1.0.2 10.4
  • Bug fixed on filter insertion
  • Regression bug fixed in layer handling
08/20/2005 1.0.1 10.4
  • Two memory leaks fixed
08/16/2005 1.0 final 10.4
  • Enhanced interface with more space for the image
  • Update on cursor management
  • In filters' popup menu, filters are sorted by categories with previews
  • New option to merge layers
  • CoreImage tools rewritten to be able to be used on transformed layers
  • Opens correctly images off all dpi and always saves in 72dpi
  • Image dragged to a new window has its size correctly taken into account
  • When opening images, zoom is adjusted for the image to fit the window
  • Video demo added in "Help"
  • Software update added
  • "Save As" bug with rhif files fixed
  • Visual zoom bug fixed
  • Chinese localization
06/13/2005 1.0 ß5 10.4
  • New background grid
  • New option at the bottom right of the window to hide filters' interface
  • New duplication tool
  • Bug fixes
  • Better Spotlight support : now RHIF files are recognized as images files
  • Copy and Paste of image added
  • Universal binaries (PowerPC AND Intel X86 compatibility)
  • German localization
05/16/2005 1.0 ß4 10.4
  • Major Issue resolved : it was not possible to save a file as "rhif" type if it was an other file type.
  • Major Visual bug : filtered layers were cropped
  • Visual bug : after opening a non "rhif" file, there were refresh issues
05/12/2005 LiveQuartz 1.0 ß3 10.4
  • Major Issue resolved : hanging on saving files (was introduced by ß2)
  • New text tool
  • New application name and icon
05/09/2005 iMage 1.0 ß2 10.4
  • Unlimited undo is fully working
  • Images direct opening is working
  • Filters pop-up menu correctly selected
  • RHIF format is spotlight ready (you can search for a word that is in a layer name)
  • User Interface is clarified
  • French localization added
05/02/2005 iMage 1.0 ß1 10.4

First public release

Autumn 2004 Alpha 10.3

first internal builds of “iMage”


See also[edit]

References[edit]

  1. ^ "LiveQuartz". Retrieved 2018-12-04.
  2. ^ Comparison of graphics file formats

External links[edit]