User:Benjah-bmm27/MakingMolecules

From Wikipedia, the free encyclopedia
Jump to navigation Jump to search

Making molecules[edit]

I've had a few messages on my talk page asking how to make 3D images of molecules like the ones I upload.

Here's how:

  • Either download and open an existing 3D file in a format such as .mol or .pdb.
  • Or draw a structure in ChemDraw (or equivalent), then copy and paste it to DS Visualizer, which will make it 3D for you.
  • Or, finally, in DS Visualizer, go View > Toolbars > Sketching and some pencil-like icons will appear. Use these to make add atoms, chains and rings of carbon atoms. Use the periodic table button, or right-click, to get a list of elements to which you can change any of these carbons.
  • Adjust the lighting to give a sense of depth to your model - I use these settings
  • Orient the molecule in the way you'd like it to appear in your final image
  • Choose a style in which to render your molecule: CPK (van der Waals radii), ball and stick, stick, polyhedra or wire
  • Check what you see in front of you is how you want the completed image to look
  • Select File > Save As and choose a filename
  • Set the file type as Image Files (*.png, *.jpg, *.jpeg, *.bmp)
  • Select an appropriately large image size - I use 2000px height
  • Save the image
  • Edit the image in, for example, Photoshop
  • Resize the image to something sensible for Wikipedia, like 1000px width
  • this is better than saving the image to 1000px width from DS Visualizer because it makes for a smoother, antialiased image
  • Add a border of 50px to top, bottom, left and right (i.e. 100px extra height and 100px extra width)
  • Save as a high-quality PNG-24 and upload to the Commons


If this is insufficient information to get you going, just let me know and I'll do my best to help.

Have fun making molecules!

Ben

Making crystal structures[edit]

To make lattices such as lithium iodide, you need information on its crystal structure.

One of the best places to download such information is here. Search for a mineral my name or chemical composition (type (Na,Cl)- to search for minerals containing only Na and Cl). You'll usually get several options. Choose carefully, because there are often crystal structures under extreme conditions there. If you're making an illustration for an article on stibnite, for example, you'll want to show the structure at room temperature and pressure. You won't want to choose the 1000 K, 20 GPa structure!

  • First check the file you have chosen is what you actually want - click View JMOL 3-D Structure
  • If you're happy with it, click Download CIF data to get the unit cell.
  • Open the .cif file in DS Visualizer - you'll see the unit cell marked out with grey lines
  • Render it as ball-and-stick or polyhedra
  • To make the lines of the unit cell disappear, press ctrl+D and select the cell tab - then click hide or something
  • To extend the structure in 1, 2 or 3 dimensions, open Structure > Crystal Cell > Edit Parameters > Preferences tab > View Range - A is the number of unit cells along the x-axis, B is the number along the y-axis and C along the z-axis
  • Voilà

There are also quite a few inorganics here, although these are not available as unit cells - they're just pseudo-molecules. You can't make them extend to dimensions of your choice.

Be careful with CIFs!

Save yourself time and trouble. For a while, I was downloading CIFs and the crystal structures I generated from them did not look like the ones in the textbooks. Eventually I realised the reason is that with certain CIFs, DS Visualizer doesn't recognise the space group information that should be encoded in the CIF. To fix the problem, you need to know the correct space group for the structure you're drawing.

  • You may need to adjust the symmetry options to make all the atoms appear. Go Structure > Crystal Cell > Edit Parameters > Space Groups and select the correct space group from the 230 options available.
  • You may then also need to adjust the symmetry display style to get the view you want. Go Structure > Crystal Cell > Edit Parameters > Preferences and choose one of the four options from the Symmetry Style drop-down menu. The One Cell option is often the most appropriate.

Radii of atoms[edit]

To change the radius of atoms in space-filling view, go Chemistry > Element Properties, click on the element whose radius you wish to change and type the new radius into the box labelled VDW Radius (Å).

To temporarily change the size of a selected atom, select the atom (click on it, it'll go yellow), then go CTRL+D (or View > Display Style...) and adjust either Ball Size, Stick Size (applies to Stick, Ball And Stick, and Scaled Ball And Stick display styles) or CPK Scale (applies to CPK (space filling) display style).

Images[edit]

Images moved to my website after being earmarked for deletion on Wikipedia:

Colour palette[edit]

Group 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
Period
1 1
H

2
He
2 3
Li
4
Be

5
B
6
C
7
N
8
O
9
F
10
Ne
3 11
Na
12
Mg

13
Al
14
Si
15
P
16
S
17
Cl
18
Ar
4 19
K
20
Ca
21
Sc
22
Ti
23
V
24
Cr
25
Mn
26
Fe
27
Co
28
Ni
29
Cu
30
Zn
31
Ga
32
Ge
33
As
34
Se
35
Br
36
Kr
5 37
Rb
38
Sr
39
Y
40
Zr
41
Nb
42
Mo
43
Tc
44
Ru
45
Rh
46
Pd
47
Ag
48
Cd
49
In
50
Sn
51
Sb
52
Te
53
I
54
Xe
6 55
Cs
56
Ba
*
72
Hf
73
Ta
74
W
75
Re
76
Os
77
Ir
78
Pt
79
Au
80
Hg
81
Tl
82
Pb
83
Bi
84
Po
85
At
86
Rn
7 87
Fr
88
Ra
**
104
Rf
105
Db
106
Sg
107
Bh
108
Hs
109
Mt
110
Ds
111
Rg
112
Cn
113
Nh
114
Fl
115
Mc
116
Lv
117
Ts
118
Og

* Lanthanides 57
La
58
Ce
59
Pr
60
Nd
61
Pm
62
Sm
63
Eu
64
Gd
65
Tb
66
Dy
67
Ho
68
Er
69
Tm
70
Yb
71
Lu
** Actinides 89
Ac
90
Th
91
Pa
92
U
93
Np
94
Pu
95
Am
96
Cm
97
Bk
98
Cf
99
Es
100
Fm
101
Md
102
No
103
Lr