User talk:ClueBot Commons/Archives/2011/December

From Wikipedia, the free encyclopedia
Jump to: navigation, search

Wuss?

There is repeating vandalism of people changing songs to "wuss songs". On Just When I Needed You Most ClueBotNG reverted it once in July, but after that left it again. Is "wuss" a word that can be added or something, or is their an other way such edits can be spotted by the bot? Thanks. Joost 99 (talk) 11:16, 28 November 2011 (UTC)

Well, this is not good

Well, first of all, http://report.cluebot.cluenet.org/ is not loading. Second of all, if it did load, it would require a revert ID, which ClueBot III (which points here) does not appear to generate.

ClueBot III archived an open RfC here, and this is annoying and took me 15 minutes to figure this out and undo and try to make the report and so forth, so this is not good. What the huge hurry is to clean talk pages of any but the most very recently active discussions I don't know, but at any rate open RfC's shouldn't be archived. It has an {{rfc}} tag so maybe the bot could search for those. Herostratus (talk) 15:37, 29 November 2011 (UTC)

That is not a false positive. That is a misconfiguration by whoever set ClueBot III to archive that page. ClueBot III is set to archive any section not edited in 240 hours (10 days). That section had not been edited in 10 days, and ClueBot III archived it as it was instructed to do. -- Cobi(t|c|b) 18:05, 29 November 2011 (UTC)

NG down

Could somebody please explain here? Rcsprinter (talk to me) 20:35, 29 November 2011 (UTC)

Hi, I've checked ClueBot's run page, that all seems ok, set to true as per usual and not false. Can't see what's causing this myself, I've emailed Cobi and made him aware of this--5 albert square (talk) 00:44, 30 November 2011 (UTC)
Just noticed this on Damian's talk page, something to do with the servers. Hopefully Cobi may be able to give an ETA of when they'll be back.--5 albert square (talk) 00:50, 30 November 2011 (UTC)

ClueBot NG Make Issue

Hey! Before taling to you i want to say to you: Good job with ClueBot NG!. Now, when I'm compiling cluebot (and i do have the required libs), make gives me this error:

In file included from main.cpp:9:
standardprocessors.hpp: In constructor 'WPCluebot::CharsetConverter::CharsetConverter(libconfig::Setting&)':
standardprocessors.hpp:438: error: 'ICONV_SET_DISCARD_ILSEQ' was not declared in this scope
standardprocessors.hpp:438: error: 'iconvctl' was not declared in this scope
standardprocessors.hpp: In constructor 'WPCluebot::AllPropCharsetConverter::AllPropCharsetConverter(libconfig::Setting&)':
standardprocessors.hpp:474: error: 'ICONV_SET_DISCARD_ILSEQ' was not declared in this scope
standardprocessors.hpp:474: error: 'iconvctl' was not declared in this scope
make[1]: *** [cluebotng] Error 1

It is code problem, libs problem?. Let me know please. (I'm using the last revison of cluebot). 201.236.134.109 (talk) 00:58, 1 December 2011 (UTC)

To be sure, I'd need more information than that, but it looks like either your version of iconv is wrong, or not available (not installed). -- Cobi(t|c|b) 05:27, 1 December 2011 (UTC)
Oh, it was iconv ^^. But now well uhm, what files do i have to edit if i want to run Cluebot NG at my own wiki? Thank you for your time. 201.236.180.252 (talk) 21:15, 1 December 2011 (UTC)

User:ClueBot NG/Run not protected?

I just noticed that User:ClueBot NG/Run wasn't protected, so anyone can come and shut CBNG off even if it's working properly. I think it should be full-protected so that only admins have access to it. Zero TalkContribs 16:24, 1 December 2011 (UTC)

I agree. i have just submited an aplication for indefinate full pagfe protection - lets see what the outcome of that is. Oddbodz (talk) 19:52, 1 December 2011 (UTC)
Fully protecting the page defeats the purpose, which is to allow non-administrators a (rather obscure) way to shut the bot down if it's malfunctioning. Administrators needing to stop the bot can exercise their use of the block button.Crazynas t 22:01, 1 December 2011 (UTC)
User_talk:ClueBot_Commons/Archives/2011/September#Protection_of_User:ClueBot_NG.2FRun. →Στc. 00:26, 2 December 2011 (UTC)

False positive

False positive reporting is down hence leaving it here. diff. Regards, SunCreator (talk) 23:02, 2 December 2011 (UTC)

Mess up

The bot's adding almost every thing it goes through to my index. Something wrong with it? --lTopGunl (talk) 05:47, 7 December 2011 (UTC)

Still the same. --lTopGunl (talk) 16:17, 7 December 2011 (UTC)
You didn't give the bot time to update the index ... -- Cobi(t|c|b) 19:29, 7 December 2011 (UTC)
The bot is reading your template as such:
{
"archiveprefix" => " User talk:TopGun/Archives/"
"format" => " Y/F"
"age" => " 168" => 168
"minkeepthreads" => " 2" => 2
"maxkeepthreads" => " 10" => 10
"archivenow" => " {{tlu|User:ClueBot III/ArchiveNow}},{{resolved|,{{Resolved|,{{done}},{{Done}}"
=> [ " {{tlu|User:ClueBot III/ArchiveNow}}", "{{resolved|", "{{Resolved|", "{{done}}", "{{Done}}" ]
"header" => " {{talk archive navigation}}"
}
Notice that " User talk:TopGun/Archives/" is not a valid page, and not even a valid namespace. The behavior with invalid namespaces is undefined.
This also explains why your archives have a space before the year in them. -- Cobi(t|c|b) 19:39, 7 December 2011 (UTC)

Mess up

The bot's adding almost every thing it goes through to my index. Something wrong with it? --lTopGunl (talk) 05:47, 7 December 2011 (UTC)

Still the same. --lTopGunl (talk) 16:17, 7 December 2011 (UTC)
You didn't give the bot time to update the index ... -- Cobi(t|c|b) 19:29, 7 December 2011 (UTC)
The bot is reading your template as such:
{
"archiveprefix" => " User talk:TopGun/Archives/"
"format" => " Y/F"
"age" => " 168" => 168
"minkeepthreads" => " 2" => 2
"maxkeepthreads" => " 10" => 10
"archivenow" => " {{User:ClueBot III/ArchiveNow}},{{resolved|,{{Resolved|,{{done}},{{Done}}"
=> [ " {{User:ClueBot III/ArchiveNow}}", "{{resolved|", "{{Resolved|", "{{done}}", "{{Done}}" ]
"header" => " {{talk archive navigation}}"
}
Notice that " User talk:TopGun/Archives/" is not a valid page, and not even a valid namespace. The behavior with invalid namespaces is undefined.
This also explains why your archives have a space before the year in them. -- Cobi(t|c|b) 19:39, 7 December 2011 (UTC)
Got it and fixed. Thank you. :) --lTopGunl (talk) 22:17, 8 December 2011 (UTC)
Any way to get around the index to display in true chronological order rather than that of the archive created first? --lTopGunl (talk) 22:17, 8 December 2011 (UTC)
Easiest way would be to copy the content, then delete (or tag for deletion with {{db-user}}) and then recreate them in the order you want. -- Cobi(t|c|b) 23:34, 8 December 2011 (UTC)
That would screw attribution I guess. --lTopGunl (talk) 23:28, 8 December 2011 (UTC)
Attribution is still lost for anything unsigned when the bot copies the text from your talk page (in normal instances). -- Cobi(t|c|b) 23:34, 8 December 2011 (UTC)

──────────────────────────────────────────────────────────────────────────────────────────────────── There's a link to follow from the edit summary. Better leave them like this then I guess? Just 3 months, not a big deal unless there's another way. --lTopGunl (talk) 23:43, 8 December 2011 (UTC)

  • Suggestion: How about the bot including the revision number/permanent link ID in the edit summary (or to be more sticking - at the end of each thread) of archiving? This would combine permanent link archiving method's credibility with this one. --lTopGunl (talk) 13:17, 9 December 2011 (UTC)

Exclusion compliance

The BRFA says that ClueBot NG is exclusion compliant. Vandals could place {{nobots}} on articles, to vandalise them a day later without the bot noticing. Is this intentional? →Στc. 05:25, 11 December 2011 (UTC)

I suppose it's simply a conflict we'll have to deal with. Always ignoring {{nobots}} is a bad idea, in my opinion. I also believe that the PHP pre-processing catches {{nobots}} and doesn't give it to the core, so we can't see if it's vandalism and ignore {{nobots}} conditionally. The only solution would to have {{nobots}} enacted on somewhere in the post-processing. But we'd need to get Cobi to code it and likely some arbitration to see if it's acceptable.
Tell you what, if someone okay's it, I'll look at the code and modify it to only revert through {{nobots}} if the vandal added the tag and ask Cobi to apply it to the running bot. -- SnoFox(t|c) 06:20, 13 December 2011 (UTC)

redirect

hat is the reason for the redirect to the page here when bot username is not ClueBot Commons? It would be more logical that the discussion had the same side as the bot. --80.161.143.239 (talk) 14:47, 12 December 2011 (UTC)

There are several bots that operate under the umbrella name "ClueBot" -- The same team of people operate all of them. It is easier if they have all of the discussion here instead of on all of the separate talk pages. -- Cobi(t|c|b) 22:12, 12 December 2011 (UTC)

Cluebot Review Interface

The Review Interface recently seems to be in a state where it will repeat the same edit for review, multiple times, after I have already categorized it. Sometimes the repeat happens immediately, sometimes a few other edits come up before the repeat. Today the repeat was diff 404142727; a few days ago I had a similar experience where 416932352 kept coming up. Let me know if you need more info. Thanks. – Wdchk (talk) 02:26, 18 December 2011 (UTC)


Today, the review interface gives a internal server error. — Preceding unsigned comment added by 50.132.64.145 (talk) 19:38, 18 December 2011 (UTC)

Is the bot down?

Is the bot down? I archive weekly and keep a max of 10 threads. It has not archived on both conditions (was previously working with no change in other settings). --lTopGunl (talk) 22:43, 18 December 2011 (UTC)

Hmmmmmmm I've checked ClueBot III's run page and that seems to be ok. I know that ClueBot NG had an issue with its server recently, I don't know if it's maybe tied in to that? I've left a message on Rich's talk page and I'll just go and leave the same message on Damian's to let them know of this discussion.--5 albert square (talk) 22:55, 18 December 2011 (UTC)
Just took a look at Cluebot III's contributions. None since 10th! --lTopGunl (talk) 22:59, 18 December 2011 (UTC)
Yes, if I remember correctly, that was around the time that ClueBot NG had it's server terminated, like I say it may well be related to that. We'll need to wait until we hear back from Rich or Damian.--5 albert square (talk) 23:11, 18 December 2011 (UTC)
Hmm. --lTopGunl (talk) 23:17, 18 December 2011 (UTC)
It's as I thought, it is related because ClueBot III is moving servers, same as ClueBot NG. Just got this response from Rich "I am working on moving ClueBot III over to labs as well so archiving is on hold, should be up by Xmas day"--5 albert square (talk) 00:07, 19 December 2011 (UTC)
Ah, ok. Thanks. --lTopGunl (talk) 00:12, 19 December 2011 (UTC)
 Done - Rich(MTCD)T|C|E-Mail 13:23, 19 December 2011 (UTC)
Great. Thanks. --lTopGunl (talk) 16:18, 19 December 2011 (UTC)

Tried to report false posive

Hi. I tried to report a false positive ID 773095, but I failed your captcha 8 times and gave up. I tried to log in, that did not work either --I B d Shank (Talk Talk) 21:09, 19 December 2011 (UTC)

Just had the same problem reporting ID 773654. Please tell me how I can report it without failing the captcha 20 times (not exaggerating). Hope it gets figured out! Anyway, great bot! ReelAngelGirl (Talk) 22:39, 19 December 2011 (UTC)
ReelAngelGirl, if it helps, I just checked the bots interface and yours is showing as being reported.--5 albert square (talk) 22:48, 19 December 2011 (UTC)
Shank, so is yours--5 albert square (talk) 22:49, 19 December 2011 (UTC)
Just curious, should I revert the last edit by ClueBot NG in Asa Butterfield, or should I wait? Will it be reverted again? Thanx. ReelAngelGirl (Talk) 01:37, 20 December 2011 (UTC)
It turns out mine was not a false positive. It looked ok at first glance, but turned out to be a vandel.--I B d Shank (Talk Talk) 03:12, 20 December 2011 (UTC)

Quickly Accessing the Interfaces

Good news! You can now access the report and review interfaces by heading to either http://review.cluebot.org or http://report.cluebot.org. Going to http://www.cluebot.org will lead to the CBNG's User page. Rich(MTCD)T|C|E-Mail 01:25, 20 December 2011 (UTC)

Burn Notice

I got the Information about Season Six from Bruce Campbell. Bruce Campbell plays Sam Axe in Burn Notice. Thanks for your time. — Preceding unsigned comment added by TruthSeeker123 (talkcontribs) 20:21, 23 December 2011 (UTC)

How?>

HOW COULD YOU POSSIBLY TRACK DOWN MY EDIT SO FAST? HOW!! — Preceding unsigned comment added by 96.240.89.149 (talk) 03:17, 24 December 2011 (UTC)

Magic. →Στc. 03:22, 24 December 2011 (UTC)
Black magic and deep magic and sorcery and other types of magic. -- Cobi(t|c|b) 16:43, 24 December 2011 (UTC)

Cluebot Review Interface

The Review Interface recently seems to be in a state where it will repeat the same edit for review, multiple times, after I have already categorized it. Sometimes the repeat happens immediately, sometimes a few other edits come up before the repeat. Today, and on December 18, the repeat was diff 404142727; a few days previously I had a similar experience where 416932352 kept coming up. Let me know if you need more info. Thanks. (This thread was archived, but I reopened and updated it as the problem still exists.) – Wdchk (talk) 23:28, 21 December 2011 (UTC)

I believe that is due to the group having no edits left in to review. A page refresh should load up new edits. - Damian Zaremba (talkcontribs) 21:55, 24 December 2011 (UTC)

Please don't trust the vandals

This [1] user talk page history shows CBNG issuing a level-1, two others adding a level-2 and a level-3, CBNG adding a level-4, the vandal changing the talk page, and then CBNG issuing a level-2, all on the same day. If the warnings had been deleted by a registered editor other than the vandal I'd understand, but in this case it seems silly to scale back the last warning. Philip Trueman (talk) 19:55, 22 December 2011 (UTC)

I suppose we could look at checking the page history for the levels rather than the page content, however that would cause a level being issued then reverted legitimately to be interpreted wrongly. Most vandals from what I've seen tend to ignore their talk page so this isn't an issue. - Damian Zaremba (talkcontribs) 21:57, 24 December 2011 (UTC)

Reverts Outside the Scope of Vandalism

This is more of a minor issue. The bot did the following revert: http://en.wikipedia.org/w/index.php?title=Saints_Row:_The_Third&diff=467267786&oldid=467267763 While this is a violation of WP:No_disclaimers_in_articles, it does not qualify as WP:Vandalism. Therefore, it might be more helpful for the corrected if the edit-comment of the bot indicates that a revert was for different reasons than vandalism. Technically, this is a false positive on vandalism, but I didn't want to report it as such as it would be quite unproductive to undo good reverts.Makrom (talk) 07:59, 25 December 2011 (UTC)

Having Vandalism Problem

Hi hope this is the right place to ask for help. For the past week I and others have been reverting vandalism by 4.26.24.203 & 69.129.53.107 (I assume it's the same person) for Orko and Skeletor can we get some help? Tyros1972 (talk) 00:23, 22 December 2011 (UTC)

This isn't the place to ask :P Try WP:AN/I - Rich(MTCD)T|C|E-Mail 00:13, 24 December 2011 (UTC)

OK thanks. Tyros1972 (talk) 23:18, 25 December 2011 (UTC)

Maxlag

What does maxlag mean in the edit rate? — Preceding unsigned comment added by Ramaksoud2000 (talkcontribs) 01:29, 26 December 2011 (UTC)

The bot's edit rate is not artificially limited except when the database slaves are lagged out by more than 10 seconds, indicating heavy load. If the bot detects this condition, it waits for 10 seconds and then tries again. -- Cobi(t|c|b) 02:01, 26 December 2011 (UTC)

Not archiving?

{{User:ClueBot III/ArchiveThis|archiveprefix=User talk: Ramaksoud2000/Archives/|format=Y/F|age=48|index=yes|archivebox=yes|box-advert=yes|minarchthreads=6}} That is my template. I don't know if the servers are down or something or my template is wrong but it is not archiving my talk page. I could archive it manually but it is cooler when a bot does it... :) I had to put letters in between the brackets for the template to show but I didn't put them on My talk page Ramaksoud2000 (talk) 02:22, 26 December 2011 (UTC)

Give the bot time, and remove the space between ":" and "Ramaksoud2000", and it should work. -- Cobi(t|c|b) 02:31, 26 December 2011 (UTC)
Thanks for awesome bots!!!!!!!!!!! Ramaksoud2000 (talk) 03:58, 26 December 2011 (UTC)

CBNG IRC server/feeds down

Hi CBNG folks. Noticed there was a little down time in the past couple of days. When service was restored, it did not seem like the IRC feeds (or the entire IRC server) came back up. A lot of STiki users rely on these feeds, so it would be great if this could be fixed when you have the time. Ping me when it gets done, so I can verify the interfacing is going smoothly. Thanks, West.andrew.g (talk) 04:19, 27 December 2011 (UTC)

It should be back up now, one of the nfs servers got rebooted the other day which killed some stuff. I'm working on improving it long term and adding some monitoring (pending me re-writing a puppet manifest for it). - Damian Zaremba (talkcontribs) 16:42, 29 December 2011 (UTC)
Back-up and running smoothly. Thanks, West.andrew.g (talk) 17:07, 29 December 2011 (UTC)

"Positive" is negative

To me, "Positive" meaning a Vandalism Detected (either False or True) is not an intuitive term. Of course this is, because I am not trained or working in this matter. So I need the mental step to construct the meaning. I'd suggest these terms be explained or described in the bot´s main (user accessible) page for the half-initiated ones like me. -DePiep (talk) 22:04, 30 December 2011 (UTC)