Wikipedia talk:Vada

From Wikipedia, the free encyclopedia
  (Redirected from Wikipedia:Vada/Talk)
Jump to: navigation, search
Vada Tutorial Discussion Plugins Documentation

Excellent work[edit]

Excellent work. This interface is brilliant for me when I can't carry Huggle around or rely on Igloo. --Rsrikanth05 (talk) 19:47, 12 March 2014 (UTC)

Thanks :) Any suggestions? And @A930913: is the guy behind it all :D -Newyorkadam (talk) 21:03, 12 March 2014 (UTC)Newyorkadam
I can't think of any, but for now, I'd like to help with Documentation/Guides for this. :) --Rsrikanth05 (talk) 08:58, 13 March 2014 (UTC)
I'll talk to A930913 and ask him about this, thanks. -Newyorkadam (talk) 11:10, 13 March 2014 (UTC)Newyorkadam

Edit Summary[edit]

I noticed that when I undo an edit using Vada, the edit summary links to the User page of the user, and not their contribs. --Rsrikanth05 (talk) 11:48, 13 March 2014 (UTC)

Not sure what you mean... I see it as linking to their contribs. Is it only when you undo a certain type of edit (e.g. biased content rather than vandalism)? -Newyorkadam (talk) 12:32, 13 March 2014 (UTC)Newyorkadam
Something like this diff. --Rsrikanth05 (talk) 15:52, 13 March 2014 (UTC)

Tool is often laggy, attempts to revert wrong edits[edit]

Please see this history and this issue as well; I've been testing the tool for the past few minutes and although it generally works well, the edit displayed does not often match the edit reverted, and even if I click to revert a vandal edit, sometimes an edit revert by another user loads late. Cloudchased (talk) 15:41, 13 March 2014 (UTC)

Issues with A930313's cleaner[edit]

I commend you for trying to develop a tool to replace Reflinks. I tried running A930313's cleaner on Arizona State University in this edit using Firefox 30 and ran into the following issues:

  • The program took many minutes to run. Did it check every reference? Reflinks only checked the true bare URLs.
  • The interface is so wide that it's impossible to view the diff all on one screen. The best I could do was save the edit and then view the article's history to see what the tool did.
  • The edit summary provides a link that says Typo fixing, but it's not obvious how Wikipedia:TypoScan is related to Vada.
  • The change of isnt → isn't was within a URL, and therefore incorrect.
  • When adding {{cite web}}, the program removes existing publishers, dates, and accessdates
  • The program unnecessarily adds new dates to existing {{dead link}} templates.
  • When tagging new dead links, the program removes the existing title
  • The program incorrectly labeled http://achahockey.org/standings_org.php?ids=1059,1061,1063 as a dead link

Again, thank you for your efforts. I'll be happy to try it again when you've done more development. GoingBatty (talk) 02:52, 3 July 2014 (UTC)

P.S. I wonder why this page isn't at Wikipedia talk:Vada. GoingBatty (talk) 02:53, 3 July 2014 (UTC)

Issues with A930313's image tagger[edit]

How to Use[edit]

I put the script on my .js page. I clicked on the link. I then clicked on the logo and selected App Store. What do I do now? Thanks,  ΤheQ Editor  Talk? 18:28, 20 August 2014 (UTC)

@TheQ Editor: You just type the name of a tool in the box. For me when I click on the box it gives me a list, but if it doesn't do that for you (? Maybe different browsers...) here's a list:
  • Anti Vandal
  • WikiEdDiff
  • A930913's Cleaner
  • ClueBot Anti Vandal
  • Live Stats
  • A930913's Image Captioner
  • A930913's Unused File Detector
  • WMF Labs Paste Queuebuilder
  • A930913's Image Tagger
Click on one, hit "purchase free app", click on the logo again, and it'll be under the App Store link. Eman235/talk 06:08, 3 November 2014 (UTC)

Double clicking[edit]

I've noticed a small design issue in vada. when one click's on a revert option but it doesn't revert due to lag if the revert option is clicked again it will revert not only the edit one meant to revere but also the edit next on the list.--Jeffrd10 (talk) 15:25, 3 September 2014 (UTC)

Tools not working[edit]

The first time I tried the Anti Vandal and ClueBot Anti Vandal apps they worked, but now they're not doing anything. I get a list, but can't click on anything. Eman235/talk 00:12, 4 November 2014 (UTC)

@Eman235: Cacycle updated his wikEd script, breaking the wikEdDiff plugin. I've fixed it again. 930913 {{ping}} 02:02, 4 November 2014 (UTC)
@A930913: It seems to still only work when WikEdDiff is uninstalled. ? Eman235/talk 02:16, 4 November 2014 (UTC)
@Eman235: You tried clearing your cache? 930913 {{ping}} 02:36, 4 November 2014 (UTC)
Just now. Still not working. Eman235/talk 05:45, 4 November 2014 (UTC)
@A930913: Yes, cleared, not working, uninstalled, cleared, working, reinstalled, cleared, not working. ??? Eman235/talk 02:38, 5 November 2014 (UTC)
@Eman235: What browser are you using? Can you see if there are any JavaScript console errors? 930913 {{ping}} 13:28, 6 November 2014 (UTC)

────────────────────────────────────────────────────────────────────────────────────────────────────@A930913: IE11. What is a JS Console Error? Eman235/talk 22:06, 6 November 2014 (UTC)

Actually, never mind, it's working now. WikEdDiff looks so much better than PrettyDiff. Eman235/talk 22:05, 9 November 2014 (UTC)

Edit summaries?[edit]

Shouldn't there be (optional) edit summaries for some (if not all) functions on the Anti Vandal/ClueBot Anti Vandal tools? With Twinkle's "Rollback" module, you can leave explanations for the revert, but with Vada...see this diff. I would have liked to link MOS:SECTIONCAPS, (I later did, with Twinkle), but as it is I couldn't. So anyway, I think having an edit summary option would be helpful.

P.S. This page really should be at Wikipedia talk:Vada. That way there would be a new section button. Any reason why it's not? Eman235/talk 02:06, 16 November 2014 (UTC)

@Eman235: Moved to Wikipedia talk:Vada. -Newyorkadam (talk) 02:25, 2 January 2015 (UTC)Newyorkadam
@Newyorkadam: Thanks! Eman235/talk 07:37, 2 January 2015 (UTC)

[edit]

Would it be possible to add the logo, or emblem, or whatever it is, to Commons? It seems to be located here. Eman235/talk 18:44, 18 August 2015 (UTC)

Not working?[edit]

The apps are not being displayed when I run it. Help? Eman235/talk 04:32, 20 November 2015 (UTC)

Still not working -- the JavaScript console is spewing out "Unsupported rc type: categorize" and the program just looks like this. Eman235/talk 20:12, 19 April 2016 (UTC)