From Wikipedia, the free encyclopedia
Jump to: navigation, search
WikiProject Free Software / Software / Computing  (Rated C-class, Mid-importance)
WikiProject icon This article is within the scope of WikiProject Free Software, a collaborative effort to improve the coverage of free software on Wikipedia. If you would like to participate, please visit the project page, where you can join the discussion and see a list of open tasks.
C-Class article C  This article has been rated as C-Class on the project's quality scale.
 Mid  This article has been rated as Mid-importance on the project's importance scale.
Taskforce icon
This article is supported by WikiProject Software (marked as Low-importance).
Taskforce icon
This article is supported by WikiProject Computing (marked as Low-importance).


Does FreeDOS and/or FreeDOS-32 support Unicode? I know the original MS-DOS did not, but was curious if FreeDOS does. —The preceding unsigned comment was added by (talkcontribs) . 19:24, 30 August 2006 (UTC)

I believe not. The FreeDOS wiki says nothing on the subject. The only mention of UTF-8 is in a description of a graphical browser for DOS which happens to support it. -- Pingumeister (talk) 19:31, 6 June 2014 (UTC)

With Win9x[edit]

With this diff [1] I am removing a bunch of superfluous information. The point of this tiny paragraph is to state that FreeDOS can not be used as the bootloader for Win9x. It's not a general discussion of the DOS usage of Win9x, which was incorrect anyways. In discussion of a bootloader, it is irrelevant whether DOS was available as a separate product. "will refuse to run on anything but versions of MS-DOS that came with them" is a POV statement, it's not about refusal, it's a basic design issue that DOS is being avoided entirely. This was also a recent edit that prompted my edit. "As a result, FreeDOS can not run Windows 95, 98, or Millennium Edition" Yes, that says the same thing the previous sentence did. We do not need to repeat ourselves. I also cut the list of boot-managers to only mention the one that comes with FreeDOS. We don't need a list, because any number of dozens can manage this. SchmuckyTheCat (talk) 04:13, 18 December 2007 (UTC)


The lead section says there is no default GUI, however, one can type "dosshell" and get to a GUI, although adding this to the installation options is required, I think. (talk) 20:09, 13 January 2014 (UTC)

Link does not work without www?[edit]


Matthiaspaul is reporting that is not working without www for him. Of course, it works for me without www. (Firefox on Windows 7) So, I am a bit concerned. Could anyone else please try reproduce?

To reproduce, one has to manually enter "" into the title bar.

Best regards,
Codename Lisa (talk) 14:14, 9 August 2014 (UTC)

Did you click on the link (in old revisions of this page) or did you enter the URL into the title bar? In the later case, the browser may auto-probe a number of common variants (including the link with www. added) after it has failed without it. Typing it into the title bar works for me as well, but clicking on the link without the www. doesn't. There are several possible reasons for this.
In general, it is invalid to assume that www.d.tld and d.tld are the same (although many web servers are configured to treat them this way for convenience) - these could even be different servers. Suppressing parts of the URL can even become a security issue.
I think, if available, we should use the URL as provided in the product documentation - if they use www or whatever, or if they specify a particular protocol, they might have their reasons - at least they will know their server configuration and will know what they documented in their documentation. Also, it is more likely that they will make sure that "documented" URLs will continue to work even when the site changes, whereas variants, which only worked "by chance" of a particular configuration may not. --Matthiaspaul (talk) 16:21, 9 August 2014 (UTC)
I tested it in all the ways I could imagine, in several different web browsers.
Maybe it is my DNS server that is being smart.
Best regards,
Codename Lisa (talk) 16:21, 10 August 2014 (UTC)
$ curl
curl: (6) Could not resolve host:
In short: your browser is being "smart". Keφr 08:13, 10 August 2014 (UTC)
Thanks. I tried nslookup just now and my DNS returns a non-authoritative redirect leading to instead. It appears sometimes, one editor alone cannot do all the testing by himself. Best regards, Codename Lisa (talk) 16:35, 10 August 2014 (UTC)